Welcome to the H4O - HUMMER 4x4 Off Road.
Results 1 to 9 of 9
  1. #1
    Baja

    Join Date
    Jun 2012
    Location
    Ridgecrest, California
    Posts
    1,281
    Thanks
    119
    Thanked 197 Times in 145 Posts

    H3 quit blowing hot air - Blower works

    I did the HVAC calibration. The resister mod was completed years ago. Just no heat. Any quick tips? A forum search suggested a mixing valve actuator?
    2006 H3 Adventure

  2. #2
    Low Profile
    Join Date
    Jan 2014
    Location
    Utah
    Posts
    78
    Thanks
    44
    Thanked 24 Times in 16 Posts
    I’ve had this happen to me from a thermostat failed to open not allowing it to come up to temperature. Cheap and easy fix. I’d start there if you haven’t checked that yet.

  3. #3
    Baja

    Join Date
    Jun 2012
    Location
    Ridgecrest, California
    Posts
    1,281
    Thanks
    119
    Thanked 197 Times in 145 Posts
    I've replaced the thermostat years ago. That gave a code because it wouldn't come up to temp fast enough. No codes at this time.
    2006 H3 Adventure

  4. #4
    Low Profile
    Join Date
    Jan 2018
    Location
    Freeborn
    Posts
    73
    Thanks
    33
    Thanked 1 Time in 1 Post
    Quote Originally Posted by poncho1965 View Post
    I've replaced the thermostat years ago. That gave a code because it wouldn't come up to temp fast enough. No codes at this time.
    Could still be the stat...


    Sent from my iPhone using Tapatalk

  5. #5
    Low Profile
    Join Date
    Sep 2011
    Location
    Blacksburg, VA
    Posts
    190
    Thanks
    0
    Thanked 31 Times in 26 Posts
    Check your Coolant Level if you haven't already.
    06 H3 Lux Totaled
    08 H3 Lux Traded
    10 H3 Alpha/Offroad

  6. #6
    Baja

    Join Date
    Jun 2012
    Location
    Ridgecrest, California
    Posts
    1,281
    Thanks
    119
    Thanked 197 Times in 145 Posts
    Coolant level is good, temp comes up quickly and does not overheat. Blending door motor operates. What am I overlooking?

  7. #7
    Baja

    Join Date
    Jun 2012
    Location
    Ridgecrest, California
    Posts
    1,281
    Thanks
    119
    Thanked 197 Times in 145 Posts
    Quote Originally Posted by Korby7 View Post
    I’ve had this happen to me from a thermostat failed to open not allowing it to come up to temperature. Cheap and easy fix. I’d start there if you haven’t checked that yet.
    Are you talking the main engine thermostat, or is there another one exclusive to the heating system?

  8. #8
    Mud Terrain
    Join Date
    Feb 2012
    Location
    Wisconsin
    Posts
    925
    Thanks
    8
    Thanked 111 Times in 95 Posts
    Starting looking into the blend door, actuator assembly controls. Also, take the time to verify that it is indeed not a plugged up heater core.

  9. #9
    Baja

    Join Date
    Jun 2012
    Location
    Ridgecrest, California
    Posts
    1,281
    Thanks
    119
    Thanked 197 Times in 145 Posts
    Quote Originally Posted by Happy Hummer View Post
    Starting looking into the blend door, actuator assembly controls. Also, take the time to verify that it is indeed not a plugged up heater core.
    Yep, was looking at the drivers side, there are three of them. Two worked but one did not. I removed it, and the heat is mysteriously working now. All functions work without this actuator installed. Heat, cold, floor, dash, defrost, you name it. So at this point I'm not sure. It's not the temperature blend door, or the one that diverts the air where you want it. Not sure of its function. ???
    Last edited by poncho1965; 10-27-2018 at 02:34 PM.
    2006 H3 Adventure


 

Similar Threads

  1. Airbag light on and Horn simultaneously quit
    By 09hummerh3 in forum HUMMER H3 2006-2010; H3T 2009-2010
    Replies: 10
    Last Post: 02-16-2016, 10:50 AM
  2. AC Blower Not Blowing
    By cdarveaux in forum HUMMER H3 2006-2010; H3T 2009-2010
    Replies: 18
    Last Post: 05-06-2013, 10:34 PM
  3. engine quit on the trail
    By freeze in forum HUMMER H1 1992-2006
    Replies: 9
    Last Post: 10-05-2012, 09:03 PM
  4. Quit Thanking Me!
    By twinmill28 in forum The Firepit
    Replies: 19
    Last Post: 08-02-2012, 01:53 PM
  5. Base Radio Left Channel Quit
    By Doc Olds in forum HUMMER H3 2006-2010; H3T 2009-2010
    Replies: 9
    Last Post: 10-31-2011, 01:49 PM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Logout