Welcome to the H4O - HUMMER 4x4 Off Road.
Page 20 of 22 FirstFirst ... 1016171819202122 LastLast
Results 286 to 300 of 320
  1. #286
    All Terrain
    Join Date
    May 2018
    Location
    Alabama
    Posts
    692
    Thanks
    23
    Thanked 116 Times in 100 Posts
    Quote Originally Posted by Iwillnc View Post
    Yes sir, let me know if you have any further questions.
    Will do.


    Sent from my iPhone using Tapatalk

  2. #287
    Chapter President

    Join Date
    Sep 2011
    Location
    Central Florida
    Posts
    1,197
    Thanks
    192
    Thanked 201 Times in 139 Posts
    I can confirm this is a easy repair if all your doing is swapping the module. I did this a few years ago. The repair on the circuit board is actually not to hard to do if you want to rebuild it yourself. I'll have to look for the info, but I'm sure its online somewhere. Its been years since I had to do this repair.
    B I G 2 D A B A N K

    2005 H2 SUT, Desert Sand

  3. #288
    All Terrain
    Join Date
    May 2018
    Location
    Alabama
    Posts
    692
    Thanks
    23
    Thanked 116 Times in 100 Posts
    Quote Originally Posted by Big2dabank View Post
    I can confirm this is a easy repair if all your doing is swapping the module. I did this a few years ago. The repair on the circuit board is actually not to hard to do if you want to rebuild it yourself. I'll have to look for the info, but I'm sure its online somewhere. Its been years since I had to do this repair.
    Thanks.


    Sent from my iPhone using Tapatalk

  4. #289
    All Terrain
    Join Date
    May 2018
    Location
    Alabama
    Posts
    692
    Thanks
    23
    Thanked 116 Times in 100 Posts
    When this started I couldnít shift my transfer case. Will this fix that problem too or do I have multiple issues.


    Sent from my iPhone using Tapatalk

  5. #290
    Bald Tire
    Join Date
    Aug 2020
    Location
    Maidens Virginia
    Posts
    29
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Iwillnc View Post


    I imagine your dash looks something like this minus the battery light?
    Mine was doing this when i first got it , it turned out be one of the wire harness's ground point

  6. #291
    All Terrain
    Join Date
    May 2018
    Location
    Alabama
    Posts
    692
    Thanks
    23
    Thanked 116 Times in 100 Posts
    Quote Originally Posted by Booch View Post
    Mine was doing this when i first got it , it turned out be one of the wire harness's ground point
    Thanks


    Sent from my iPhone using Tapatalk

  7. #292
    Bald Tire
    Join Date
    Jan 2017
    Location
    Ny
    Posts
    21
    Thanks
    0
    Thanked 3 Times in 3 Posts
    Merry Christmas! I had some free time so I changed the driver door detent . Itís been making awful clicking noises for as long as I can remember. I got my rear end ready for another winter with no bumper and installed rain guards. Good day lolName:  IMG_6161.jpg
Views: 101
Size:  2.87 MB
    Name:  IMG_6160.jpg
Views: 91
Size:  2.74 MB
    Name:  IMG_6159.jpg
Views: 82
Size:  2.78 MB
    Name:  IMG_6158.jpg
Views: 85
Size:  2.77 MB


    Sent from my iPhone using Tapatalk

  8. The Following User Says Thank You to grod98 For This Useful Post:

    alrock (12-27-2020)

  9. #293
    Street Tire
    Join Date
    Sep 2013
    Location
    NC
    Posts
    208
    Thanks
    4
    Thanked 10 Times in 10 Posts
    Everything about that license plate setup is absolutely amazing.

  10. #294
    Bald Tire
    Join Date
    Jan 2017
    Location
    Ny
    Posts
    21
    Thanks
    0
    Thanked 3 Times in 3 Posts
    Quote Originally Posted by Iwillnc View Post
    Everything about that license plate setup is absolutely amazing.
    Thanks! Spent some time on that one


    Sent from my iPhone using Tapatalk

  11. #295
    Bald Tire
    Join Date
    Jan 2017
    Location
    Ny
    Posts
    21
    Thanks
    0
    Thanked 3 Times in 3 Posts
    Iím on a roll! Did the valley gasket and new valve covers. Almost at 200k Name:  IMG_6168.jpg
Views: 82
Size:  2.89 MB
    Name:  IMG_6167.jpg
Views: 82
Size:  2.25 MB
    Name:  IMG_6166.jpg
Views: 83
Size:  2.59 MB
    Name:  IMG_6165.jpg
Views: 84
Size:  2.67 MB


    Sent from my iPhone using Tapatalk

  12. #296
    All Terrain
    Join Date
    May 2018
    Location
    Alabama
    Posts
    692
    Thanks
    23
    Thanked 116 Times in 100 Posts
    There is a 6x6 pool of diff fluid pooled under my front differential. Looks like the driverís side seal. I am supposed to leave for a 600 mile each way trip after work on Thursday. Will be towing it behind my Motorhome. How much fluid does the differential hold? What fluid should I use to top it off.


    Sent from my iPhone using Tapatalk

  13. #297
    Street Tire
    Join Date
    Sep 2013
    Location
    NC
    Posts
    208
    Thanks
    4
    Thanked 10 Times in 10 Posts

    What did you do to your H2 recently?

    My driver side diff seal leaked for about 10 years (dealer replaced several times and it never held) up until my axles were rebuilt last year when they fixed it once and for all. Any long distance driving would cause a drop or two to come down. But never more than a weep.

    Point being if you have a 6x6 area of oil I would be very worried about taking the truck anywhere. I believe if you disconnect the CV from the axle shaft you can tap out the axle shafts (differential still in truck) and install a new seal.

    Otherwise keep the differential filled up to the drain plug and check frequently.

    Iíll have to look at the service manual to find the fluid amount...


    Sent from my iPhone using Tapatalk

  14. #298
    All Terrain
    Join Date
    May 2018
    Location
    Alabama
    Posts
    692
    Thanks
    23
    Thanked 116 Times in 100 Posts
    Thanks for the information on the front differential. Got the ECBM back yesterday and they installed it this morning. Still have every issue I had before sending it out for rebuild. ABS light still on and transfer case will not shift.


    Sent from my iPhone using Tapatalk

  15. #299
    El Diablo
    Join Date
    Sep 2011
    Location
    Scottsdale
    Posts
    9,679
    Thanks
    740
    Thanked 3,501 Times in 1,767 Posts
    When you remove the axles to put in a new seal, check the axle shafts for grooves where the axle seal rested. A failing seal can wear a groove there and a new seal will only be a stopgap fix - a new axle could be necessary. If there's any buildup at that spot be sure to clean it with a Scotchbrite pad or similar.

  16. #300
    Street Tire
    Join Date
    Sep 2013
    Location
    NC
    Posts
    208
    Thanks
    4
    Thanked 10 Times in 10 Posts
    Quote Originally Posted by MilamJR View Post
    Thanks for the information on the front differential. Got the ECBM back yesterday and they installed it this morning. Still have every issue I had before sending it out for rebuild. ABS light still on and transfer case will not shift.


    Sent from my iPhone using Tapatalk
    Well wtf? I wonder if they made sure both cables were plugged in secure?


    Sent from my iPhone using Tapatalk


 

Similar Threads

  1. Tires
    By USMC_TOP in forum HUMMER H3 2006-2010; H3T 2009-2010
    Replies: 29
    Last Post: 07-29-2015, 11:39 AM
  2. Getting new tires!
    By Bananatank in forum HUMMER H3 2006-2010; H3T 2009-2010
    Replies: 142
    Last Post: 07-13-2014, 05:38 PM
  3. Best mud tires?
    By poweraidon in forum HUMMER H3 2006-2010; H3T 2009-2010
    Replies: 14
    Last Post: 07-01-2014, 10:06 AM
  4. 5 H1 tires and rim in Co
    By Highatop in forum Online Finds
    Replies: 0
    Last Post: 05-12-2014, 02:06 PM
  5. tires?
    By nj3talpha in forum HUMMER H3 2006-2010; H3T 2009-2010
    Replies: 2
    Last Post: 11-12-2011, 07:01 PM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Logout