Welcome to the H4O - HUMMER 4x4 Off Road.
Results 1 to 15 of 15
  1. #1
    Bald Tire
    Join Date
    Apr 2021
    Location
    Montana, USA
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts

    HELP!!! ECM connecter problem

    As I'm getting closer to finishing the 5.3 LS Swap in my 06 H3, I'm finding all kinds of little electrical connector issues. Some connectors from the the donor motor don't match some just aren't even there compared to the wiring harness. I bought an OEM wiring harness for an 08 ALPHA and a 5.3 out of a Tahoe. As far as the some of the connectors not matching I can deal with either replacing the sensor or changing the connectors to work. The big one is the blue connector on the ECM. The 06 L5 computer had a slightly smaller connector and had the lockdown posts in a different position. Has anyone dealt with this problem and if so how did you fix it. The computer I bought for an 08 ALPHA works with the new wiring harness but will not connect to the blue connector on the truck that I believe runs power to the body control module ( not 100% about this). The company I bought the computer from said its not possible to do this swap.
    Attached Images Attached Images   

  2. #2
    NERD!!!

    Join Date
    Sep 2011
    Location
    Rancho Palos Verdes, CA
    Posts
    3,141
    Thanks
    2,251
    Thanked 802 Times in 483 Posts
    2008 is substantially different than 2007 or prior. There are shops that can do the mod.

    Waiting for Squeaky to chime in . . .

    Sent from my Pixel 4a (5G) using Tapatalk
    2017 Honda HR-V
    2020 Subaru Crosstrek Premium / 6 Speed - BUILD THREAD
    SOLD 2006 Hummer H3 / Adventure / 5 Speed / No Bling - BUILD THREAD

  3. #3
    Low Profile
    Join Date
    Jan 2020
    Location
    detroit
    Posts
    112
    Thanks
    13
    Thanked 21 Times in 21 Posts
    I don't know of any other solution than getting that e67 controller connector and pigtail wiring from the junkyard and then splicing into your h3 harness. Many vehicles use the e67 controller so it doesn't have to be from a h3. I might have a spare colorado e67 harness pigtail and connector if you do not have a local u pick type junkyard nearby

    Sent from my SM-G960U using Tapatalk
    Last edited by jimmy p; 07-23-2021 at 10:58 PM.

  4. #4
    Low Profile
    Join Date
    Jan 2020
    Location
    detroit
    Posts
    112
    Thanks
    13
    Thanked 21 Times in 21 Posts
    Current performance makes a jumper harnesses but only sells it as part of their full harness kit.

    Sent from my SM-G960U using Tapatalk

  5. #5
    Bald Tire
    Join Date
    Apr 2021
    Location
    Montana, USA
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I assume it would have to be 2008 or newer vehicle to get that pig tail from? Do you of a couple different vehicles off the top of your head that have it. I'm in Montana and we occasionally see a Chevy Colorado come through the yards here but I'm not sure about anything that new.

  6. #6
    Bald Tire
    Join Date
    Apr 2021
    Location
    Montana, USA
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I saw their jumper, and got really excited but like you said I couldn't find it out side of buying the $1000 dollar harness kit. I was hoping some else made such a jumper or was hoping it was possible to have someone pull the two computers apart de-pin and swap the physical connectors.

  7. #7
    Low Profile
    Join Date
    Jan 2020
    Location
    detroit
    Posts
    112
    Thanks
    13
    Thanked 21 Times in 21 Posts
    Here is the full list of e67 controller vehicles. Pretty common in the junkyards.

    https://gmflash.com/e67-pcm



    Sent from my SM-G960U using Tapatalk

  8. The Following User Says Thank You to jimmy p For This Useful Post:

    cbetts (07-25-2021)

  9. #8
    Low Profile
    Join Date
    Jan 2020
    Location
    detroit
    Posts
    112
    Thanks
    13
    Thanked 21 Times in 21 Posts
    I wasnt able to find the appropriate plugs to make it plug and play, not sure where current performance is sourcing them from. They can likely buy in bulk where i just needed one.. Splicing isn't too bad, just get some shrink wrap, solder and a solder gun and spend an hour cutting and splicing.


    I cut open a spare ecm to see if I could pull the plug out to make a jumper but it doesn't seem possible to do that or swap the plug inside the controllers. Maybe someone with some circuit board experience could do it, but not me.



    Sent from my SM-G960U using Tapatalk
    Last edited by jimmy p; 07-24-2021 at 01:08 PM.

  10. #9
    Bald Tire
    Join Date
    Apr 2021
    Location
    Montana, USA
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Awesome! This is all helping a lot. I've got the harness laid out and I've got some substantial wires that have no connecters that correspond on the truck or the motor. Click image for larger version. 

Name:	08 unknown.jpg 
Views:	93 
Size:	270.7 KB 
ID:	27641Name:  08 unknow1.jpg
Views: 90
Size:  41.1 KB

    One of which has an almost identical connection on the drivers side next to the battery but nothing to plug it into on the passenger side. Anyone have an idea where these go to?
    Name:  08 to body.jpg
Views: 89
Size:  58.9 KB

  11. #10
    Low Profile
    Join Date
    Jan 2020
    Location
    detroit
    Posts
    112
    Thanks
    13
    Thanked 21 Times in 21 Posts
    I don't see how you can do this without getting 3 wiring diagrams and cross referencing where everything goes. You need your 06 h3, the 09 h3 alpha if that is the harness you are using and whatever year and model 5.3 you are using.

    I can try to help but you will have the best success if you study the diagrams yourself.

    Sent from my SM-G960U using Tapatalk

  12. #11
    Bald Tire
    Join Date
    Apr 2021
    Location
    Montana, USA
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I've been cross referencing the 06 H3 and the 08 Alpha, the problem I'm running into even with the wiring diagrams is they don't seem to show the connections in between the wires starting and ending point. Plus the wire connections in question right now don't have a direct start or end. All four either cross through just the wiring harness or disappear into a large wire cluster that dives into the cab as well as splits and runs under the truck all the way to the rear of it. The 08 alpha wiring harness seems to have more connections then the 06 body has to connect to and some of the ones I've found that physically connect don't have wires that line up. If I could figure out where these leads ran to or ended at or even what they were supposed to control I believe I could get the wiring diagram and make the proper connections. I really apricate the help so far, I'm getting to a point where the length of this project, and want to drive my H3 again is wearing on me.

  13. #12
    Low Profile
    Join Date
    Jan 2020
    Location
    detroit
    Posts
    112
    Thanks
    13
    Thanked 21 Times in 21 Posts
    What wiring diagrams are you using? Also I think you were the guy that bought my 09 alpha engine harness right? The 08 and 09 have different wiring outputs to the body so that might be part of the problem.

    Sent from my SM-G960U using Tapatalk

  14. #13
    Bald Tire
    Join Date
    Apr 2021
    Location
    Montana, USA
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I think I am the one that bought your wiring harness, I thought it was an 08. I've been using schwarttzy diagrams, but I have been looking at the 08 not the 09.

  15. #14
    Bald Tire
    Join Date
    Apr 2021
    Location
    Montana, USA
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I'm not sure why or how I got it in my head that it was an 08 harness. Do you have any good references for an 09 diagram?

  16. #15
    Low Profile
    Join Date
    Jan 2020
    Location
    detroit
    Posts
    112
    Thanks
    13
    Thanked 21 Times in 21 Posts
    I haven't used this myself but it might be worth a shot for the h3 diagrams. Ebay link below:


    You never mentioned what year tahoe your 5.3 came from?

    https://www.ebay.com/itm/Hummer-H3-2...-127632-2357-0

    Sent from my SM-G960U using Tapatalk
    Last edited by jimmy p; 08-30-2021 at 07:08 PM.


 

Similar Threads

  1. Heater problem
    By glpd74 in forum HUMMER H2 2003-2009
    Replies: 2
    Last Post: 11-09-2017, 12:04 AM
  2. H3 Different SVC 4WD Problem
    By KH321 in forum HUMMER H3 2006-2010; H3T 2009-2010
    Replies: 3
    Last Post: 11-05-2017, 11:37 PM
  3. Help me, I have a problem
    By High Five H2 in forum HUMMER talk
    Replies: 29
    Last Post: 07-02-2017, 05:09 PM
  4. AC problem
    By Scarsman in forum HUMMER H2 2003-2009
    Replies: 20
    Last Post: 06-25-2015, 12:00 AM
  5. New Problem. Uh-oh.
    By HUMMERADDICT in forum HUMMER H3 2006-2010; H3T 2009-2010
    Replies: 8
    Last Post: 07-24-2012, 01:47 PM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Logout