Welcome to the H4O - HUMMER 4x4 Off Road.
Results 1 to 8 of 8
  1. #1
    Low Profile
    Join Date
    Jan 2020
    Location
    detroit
    Posts
    99
    Thanks
    9
    Thanked 18 Times in 18 Posts

    H3 onstar delete

    As I was splicing wires for my engine swap I noticed a single wire and inline fuse coming off the battery. It looks like this is for onstar. Does anyone know why this gets its own inline fuse rather than using a fuse in the fuse block?

    Also has anyone removed the onstar module and associated components all together? I am looking to clean up and simplify my wiring, just wondering if anyone has succesfully bypassed it?

  2. #2
    Super Swamper
    Join Date
    Feb 2013
    Location
    AB, Canada
    Posts
    3,883
    Thanks
    1,181
    Thanked 513 Times in 405 Posts
    I do remember someone posting about this years ago, they unplugged something behind the radio if I recall correctly.
    2009 Hummer H3T Alpha

  3. #3
    Baja
    Join Date
    Sep 2011
    Location
    massachusetts
    Posts
    1,083
    Thanks
    217
    Thanked 286 Times in 202 Posts
    I unplugged mine only annoying thing is that there is a small red LED light on the mirror showing error with onstar
    Current:

    2006 Red H3 Adventure/ luxury- 37" iroks, HD tierods, steering rack kit, custom front IFS HP Dana 44 diff with Yukon zip locker, Np241 manual T-case, 6.0L VVT/ 6L90 swap

    2008 Black H3 Alpha- HD tierods, steering rack kit, Custom HD lower control arm bushing kit

    2007 Black H3 Luxury- 1.25" bodylift, elocker, 4:1 t-case, steering rack kit, custom front IFS HP Dana 50 diff with truetrac, 37" bfg km2, H3x 18" wheels

    2009 Black H3T base- custom front IFS HP Dana 44 diff with truetrac, 37" centennial trail hogs, H3x 18" wheels

    2008 White H3 Adventure

    I think we might have too many of these things now...

  4. #4
    Super Swamper
    Join Date
    Oct 2011
    Location
    FT. Carson, CO
    Posts
    2,026
    Thanks
    434
    Thanked 225 Times in 175 Posts
    Quote Originally Posted by atvspeed4 View Post
    I unplugged mine only annoying thing is that there is a small red LED light on the mirror showing error with onstar
    Really? I pulled the whole box and XM with no red light popping up on my mirror?
    No one is more professional than I. I am a Noncommissioned Officer, a leader of Soldiers.

  5. #5
    Bald Tire
    Join Date
    Jun 2020
    Location
    cold & windy
    Posts
    49
    Thanks
    0
    Thanked 3 Times in 3 Posts
    Quote Originally Posted by SolidusJ View Post
    Really? I pulled the whole box and XM with no red light popping up on my mirror?
    ain't tried it myself yet, but maybe it has something to do with the OnStar module being there & not working like it thinks it should (generating the fault light in the mirror) versus the module not being there at all (thereby not sending a status).

    just spitballing, though

  6. #6
    Low Profile
    Join Date
    Jan 2020
    Location
    detroit
    Posts
    99
    Thanks
    9
    Thanked 18 Times in 18 Posts
    Ok thanks, that gives me some confidence to remove xm and onstar. My rearview mirror is already unplugged and covered by my backup camera mirror so no worries there.

  7. #7
    Super Swamper
    Join Date
    Oct 2011
    Location
    FT. Carson, CO
    Posts
    2,026
    Thanks
    434
    Thanked 225 Times in 175 Posts
    Quote Originally Posted by jimmy p View Post
    Ok thanks, that gives me some confidence to remove xm and onstar. My rearview mirror is already unplugged and covered by my backup camera mirror so no worries there.
    Yeah, I did that same with cleaning up the wires back there and such about a year ago. You should be fine, I only did it because I got sick and tired of the GMOS going bad on me. Only down side that's not an issue to me was losing the RAP and door chime.
    Name:  95293241_316949349273647_4690081107293503488_n.jpg
Views: 144
Size:  45.8 KB
    No one is more professional than I. I am a Noncommissioned Officer, a leader of Soldiers.

  8. #8
    Bald Tire
    Join Date
    Nov 2016
    Location
    Tennessee
    Posts
    15
    Thanks
    0
    Thanked 1 Time in 1 Post
    Quote Originally Posted by jimmy p View Post
    As I was splicing wires for my engine swap I noticed a single wire and inline fuse coming off the battery. It looks like this is for onstar. Does anyone know why this gets its own inline fuse rather than using a fuse in the fuse block?

    Also has anyone removed the onstar module and associated components all together? I am looking to clean up and simplify my wiring, just wondering if anyone has succesfully bypassed it?
    It may have its own fuse set up that way so you don't get any of the electrical hum or interference. My Ram has an inline fuse independent of the fuse box for the radio and thats what I was told.

    Sent from my SM-N960U using Tapatalk


 

Similar Threads

  1. How to disconnect Onstar in the H3
    By deserth3 in forum Tech Library
    Replies: 9
    Last Post: 06-15-2017, 02:29 PM
  2. H3 BCM Bypass/Delete
    By Griff22usmc in forum HUMMER H3 2006-2010; H3T 2009-2010
    Replies: 28
    Last Post: 09-04-2013, 09:23 AM
  3. Removal of my Onstar...
    By Highatop in forum HAM, GMRS, Navigation, Electronics
    Replies: 16
    Last Post: 08-14-2013, 05:32 AM
  4. H3 XM/Onstar both died!
    By poncho1965 in forum HUMMER H3 2006-2010; H3T 2009-2010
    Replies: 10
    Last Post: 11-20-2012, 09:36 AM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Logout