Welcome to the H4O - HUMMER 4x4 Off Road.
Page 2 of 2 FirstFirst 12
Results 16 to 18 of 18
  1. #16
    Super Swamper
    Join Date
    Jun 2015
    Location
    Way up north, UT
    Posts
    2,190
    Thanks
    567
    Thanked 623 Times in 438 Posts
    Talked to the guy that did my diff a bit. He says he is willing to fix it for me, but I haven't heard from him since then, so I'm not sure if I really want to go to the trouble of pulling the entire axle housing out of the truck again and driving it close to 2 hours down to his shop to have him put it all back together for me.

    I did talk to ARB though and they are sending me new o-rings and the bonded seal under warranty. They are sending them Fedex 2 day it looks like, they should be here Thursday.

    I also bought a new set of bearings from Napa yesterday but they only had SKF "premium bearings" made in China (almost $30 a piece...), so after I realized I was going to be taking more than a day or so to get this all sorted out I ordered some Timken's off Amazon. They actually ended up only taking overnight to get to me, they came in this afternoon. Less than $36 shipped for the pair. Took the SKF bearings back to Napa and got my $60 back.

    Figured out a way to splice the copper line back together by taking a brass 3/16 tubing splice (the "Christmas tree" kind), cutting the ends off to leave the middle, then drilling it out with a 9/64" drill bit and then soldering it all together with some high strength lead free solder.

    Hopefully at some point I'll have this all sorted out and can get back to enjoying my H3.



    Rusty jam nut for the bulkhead fitting:




    Spliced copper line:

    2008 H3 Alpha

    "Live free or die: Death is not the worst of evils." - General John Stark

    N1JPA

  2. #17
    Super Swamper
    Join Date
    Jun 2015
    Location
    Way up north, UT
    Posts
    2,190
    Thanks
    567
    Thanked 623 Times in 438 Posts
    Seals arrived Wednesday, ended up not getting around to installing them until today. No leaks now! But of course I forgot to put the side gear back in, and then when I took it back apart to get that in I realized I might have put the bonded seal in backwards. So now I am waiting on ARB to reply to my email about that question. But it's looking better now. Hopefully I'll have this back together soon.
    2008 H3 Alpha

    "Live free or die: Death is not the worst of evils." - General John Stark

    N1JPA

  3. #18
    Super Swamper
    Join Date
    Jun 2015
    Location
    Way up north, UT
    Posts
    2,190
    Thanks
    567
    Thanked 623 Times in 438 Posts
    Finally got a hold of the diff guy. Taking the axle housing out tonight and taking it all down to him tomorrow morning. He's going to put the carrier back in for me while I am at work tomorrow so tomorrow night I should have this thing all buttoned back up.
    2008 H3 Alpha

    "Live free or die: Death is not the worst of evils." - General John Stark

    N1JPA


 

Similar Threads

  1. Rear Locker not engaging - no warning lights
    By H32NV in forum HUMMER H3 2006-2010; H3T 2009-2010
    Replies: 5
    Last Post: 05-24-2017, 09:03 AM
  2. H3 Air Conditioner Clutch Not Engaging
    By Humvdood in forum HUMMER H3 2006-2010; H3T 2009-2010
    Replies: 6
    Last Post: 11-06-2014, 11:59 PM
  3. locker
    By digglesworth in forum HUMMER H3 2006-2010; H3T 2009-2010
    Replies: 54
    Last Post: 06-29-2014, 10:18 PM
  4. Transfer case engaging in 4 Hi
    By Azjohn in forum HUMMER H3 2006-2010; H3T 2009-2010
    Replies: 9
    Last Post: 10-18-2013, 06:35 PM
  5. Locker?
    By 05Mudiak in forum HUMMER talk
    Replies: 5
    Last Post: 11-30-2011, 05:11 AM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Logout