Welcome to the H4O - HUMMER 4x4 Off Road.
Results 1 to 5 of 5
  1. #1
    Bald Tire
    Join Date
    May 2012
    Location
    Maryland
    Posts
    7
    Thanks
    0
    Thanked 2 Times in 1 Post

    Need Help, codes are stumping me

    I am really stumped and need some serious help. I keep getting a stabilitrac error (no ABS light or error). It is not when I first start the H3, it is after I drive. Could be a short distance or a long distance, but the error comes back with no rhyme or reason. It used to be an occasional thing, now it is every time I drive. The vehicle drives fine and I don't notice any shifting or performance issues, just able to spin back wheels in the rain when the light is on.
    The first codes were:
    C0329 Transfer case encoder circuit low
    C0276 TCM communication performance
    I replaced the encoder motor but still got the code:
    C0276 TCM Communication performance
    I took it to my mechanic and he got:
    C0329 Encoder Circuit Low
    U1017 Lost communication with engine control module
    He cleared the codes and drove it and got:
    C0276 Transmission control module communication performance
    I am at a complete loss as to the cause. Please send help quickly!

  2. #2
    "Like Nothing Else"
    Join Date
    Sep 2011
    Location
    Indianapolis, IN
    Posts
    3,319
    Thanks
    711
    Thanked 475 Times in 364 Posts
    What do your battery terminals look like? the OEM are kinda crappy and are often times the cause of weird electrical gremlins. You could try installing new ones and seeing if that helps.
    -2009 H3 Alpha/Adv||SAS/SOA
    -2008 H3 Alpha-RIP

  3. #3
    El Diablo
    Join Date
    Sep 2011
    Location
    Scottsdale
    Posts
    9,407
    Thanks
    697
    Thanked 3,416 Times in 1,711 Posts
    A weak battery can cause weird issues. My last one was Stab Sys and ABS issues and a new battery fixed that. Previous one caused the engine to stumble

  4. #4
    Super Swamper
    Join Date
    Oct 2012
    Location
    Bellflower, CA
    Posts
    2,040
    Thanks
    501
    Thanked 457 Times in 328 Posts
    x3 on the battery and connections.
    2006 H3 Adventure & modified Rancho with SOA

  5. #5
    Bald Tire
    Join Date
    May 2012
    Location
    Maryland
    Posts
    7
    Thanks
    0
    Thanked 2 Times in 1 Post
    Thanks for the suggestions. I found two contacts on the transfer case control module oh so slightly corroded. When I opened up the module there was a dot of corrosion, just enough to kill the unit. THis is likely from a sunroof leak 5 years ago

  6. The Following 2 Users Say Thank You to CARdiac For This Useful Post:

    alrock (03-25-2020), RamRod (03-25-2020)


 

Similar Threads

  1. H3 I got some codes today...
    By H3BigBoy in forum HUMMER H3 2006-2010; H3T 2009-2010
    Replies: 5
    Last Post: 11-11-2019, 05:22 PM
  2. Strange messages/codes
    By Vdawg1115 in forum HUMMER H3 2006-2010; H3T 2009-2010
    Replies: 12
    Last Post: 11-24-2016, 11:44 PM
  3. 2006 hummer h3 codes
    By nosral1221 in forum HUMMER H3 2006-2010; H3T 2009-2010
    Replies: 3
    Last Post: 04-06-2016, 01:52 PM
  4. Engine Codes on H3 Hummer
    By Schwarttzy in forum HUMMER H3 2006-2010; H3T 2009-2010
    Replies: 0
    Last Post: 09-21-2015, 09:33 PM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Logout