Welcome to the H4O - HUMMER 4x4 Off Road.
Results 1 to 11 of 11
  1. #1
    Super Swamper


    Join Date
    Sep 2011
    Location
    Arkansas
    Posts
    2,286
    Thanks
    222
    Thanked 556 Times in 353 Posts

    air cleaner indicator

    Alpha started hesitating and would not accelerate. Did not show limp mode. First thought was tranny may be going. Got home and checked the indicator and the rubber reset button looked melted and distorted. Air cleaner did not really look dirty. So I put in a new filter, problem solved. Auto Zone nor O'reillys had one.
    Amazon for $16. GM $65 hmmm. Look the same quality. Ordered a new one just because the filter did not look dirty but apparently was. So the little device helped solve the mystery. Currently running without it but will replace for ease of checking filter condition. Off to the boonies.............

  2. #2
    Mud Terrain
    Join Date
    Jun 2014
    Location
    United States
    Posts
    805
    Thanks
    197
    Thanked 131 Times in 105 Posts
    Yeah donít trust those indicators. It isnít that hard to open the air box up a look at the filter anyway.


    Sent from my iPhone using Tapatalk

  3. #3
    Mud Terrain
    Join Date
    Jun 2014
    Location
    United States
    Posts
    805
    Thanks
    197
    Thanked 131 Times in 105 Posts
    Oh and put your air filter back in lol.

    You should probably clean the intake too...


    Sent from my iPhone using Tapatalk

  4. #4
    Super Swamper


    Join Date
    Sep 2011
    Location
    Arkansas
    Posts
    2,286
    Thanks
    222
    Thanked 556 Times in 353 Posts
    I was not dressed to work on hot engine in 110 heat index. It takes some time to get mine off and on correctly. The litte thing was correct but at 98,000 has reached end of life.

  5. #5
    El Diablo
    Join Date
    Sep 2011
    Location
    Scottsdale
    Posts
    8,615
    Thanks
    483
    Thanked 3,091 Times in 1,518 Posts
    Glad you got a quick and cheap resolution

    Sent from my SM-N950U using Tapatalk

  6. #6
    Super Swamper


    Join Date
    Sep 2011
    Location
    Arkansas
    Posts
    2,286
    Thanks
    222
    Thanked 556 Times in 353 Posts
    Spoke too soon. Torque converter seems more likey now after it warmed back up. Flat bed hauling it to friends shop. If that is the issue we are going to stuff upgraded parts in there. Maybe It will go another 100,000. Hope I can get to see that.

  7. #7
    Mud Terrain
    Join Date
    Sep 2011
    Location
    massachusetts
    Posts
    830
    Thanks
    137
    Thanked 149 Times in 116 Posts
    How many miles on yours? Our alpha is at 155k and has been hesitating off and on when driving on the highway. We confirmed it was the torque converter but waiting out until it gets a little worse to buy us time for a full transmission swap
    2006 Red H3 Adventure/ luxury 37" iroks, HD tierods, steering rack kit, custom front IFS HP Dana 44 diff with Yukon zip locker, Np241 manual T-case, 6.0L VVT/ 6L90 swap

    2006 Black H3 Adventure/ Luxury 5 speed manual, HD diff bushings

    2008 Black H3 Alpha HD tierods, steering rack kit, custom front IFS HP Dana 44 diff with truetrac

  8. #8
    Bogger
    Join Date
    Oct 2012
    Location
    Bellflower, CA
    Posts
    1,718
    Thanks
    381
    Thanked 362 Times in 255 Posts
    150k is a good time to consider the tranny and converter for issues. 4l60E is good but is not great from the factory.
    2006 H3 Adventure & modified Rancho with SOA

  9. #9
    Low Profile
    Join Date
    Nov 2016
    Location
    Texas
    Posts
    53
    Thanks
    13
    Thanked 12 Times in 12 Posts
    Do you happen to have a link to the amazon one you purchased for the alpha?
    2010 Hummer H3 Alpha Adventure

  10. #10
    Super Swamper


    Join Date
    Sep 2011
    Location
    Arkansas
    Posts
    2,286
    Thanks
    222
    Thanked 556 Times in 353 Posts
    Quote Originally Posted by H3V8 View Post
    Do you happen to have a link to the amazon one you purchased for the alpha?
    It says $18.14, guess it went up a couple bucks?
    https://www.amazon.com/gp/product/B0...?ie=UTF8&psc=1

  11. #11
    Super Swamper


    Join Date
    Sep 2011
    Location
    Arkansas
    Posts
    2,286
    Thanks
    222
    Thanked 556 Times in 353 Posts
    Quote Originally Posted by atvspeed4 View Post
    How many miles on yours? Our alpha is at 155k and has been hesitating off and on when driving on the highway. We confirmed it was the torque converter but waiting out until it gets a little worse to buy us time for a full transmission swap
    98,000 plus, mine started shifting harder when I was merging but fluid level was ok. Then I smelled it. Burnt. better not wait you may be stranded when it goes.

    We checked some sites claiming upgraded versions but soon started to see walking down the parts shelves they were showing stock parts and claiming better ones? Hmm. then some flowery wording for things that my friend's shop said were standard procedure for them. They are going to do a few tweaks but not much. If I get another 98,000 I'm good with that.
    I looked into a double deep pan, about 3 more quarts but clearance may be a problem with my Knight full skid. Finned aluminum, not painted is what I was thinking. Not sure the regular capacity would make much difference. The Alpha has a formed in side for the drive shaft. Not sure if the sites I looked at that listed the tranny would work on the H3. Decided to wait on that.
    Also used a spare stock cross member for the transfer I had stuck back. Also a side mount which required removing the cv which had a torn boot anyway and stuck in a new one I had.
    I should have it together by Tuesday.


 

Similar Threads

  1. injector cleaner
    By SolidusJ in forum HUMMER H3 2006-2010; H3T 2009-2010
    Replies: 33
    Last Post: 04-21-2014, 07:23 PM
  2. Serv 4wd indicator
    By ProjektH3 in forum HUMMER H3 2006-2010; H3T 2009-2010
    Replies: 9
    Last Post: 04-15-2014, 10:38 AM
  3. K&N cleaner for airaid filter?
    By Fish in forum HUMMER H2 2003-2009
    Replies: 2
    Last Post: 08-23-2012, 09:05 PM
  4. Intermittent t-case indicator
    By mudbug in forum HUMMER H2 2003-2009
    Replies: 1
    Last Post: 01-28-2012, 08:01 PM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Logout