Welcome to the H4O - HUMMER 4x4 Off Road.
Results 1 to 4 of 4
  1. #1
    Baja
    Join Date
    Jun 2015
    Location
    West Valley, UT
    Posts
    1,445
    Thanks
    378
    Thanked 436 Times in 290 Posts

    H3 ignition switch troubleshooting

    So recently I had been having trouble with the whole "turn the key and Passlock makes you late for work" issue a lot of us are encountering now that our vehicles are getting up there in years. I noticed mine at least only seemed to act up when it was below freezing out. During the warmer months I never had any issues.

    I finally got sick of it and decided to try disassembling the ignition switch to see just what might be causing the problem. I know some people blamed it on having a bunch of stuff on your keys, and there were other reasons people gave as well, so I wanted to see what it really was.

    After pulling the switch out and disassembling it, I determined several things, and formed at least one hypothesis for the failures.

    First thing is, the ignition switch itself is easily removed and replaced without needing to mess around with the tumbler. You can get a brand new one for about $40-$50 or so and simply swap it out and supposedly do a relearn procedure, or take it to someone with a Tech 2 and have the relearn done that way.

    Another is that the resistor for the whole Passlock setup is located as an integral part of the ignition switch itself, and with the way the switch is designed it will be physically destroyed if someone does manage to pull the tumbler out and try to use a screwdriver to start the car. It's also improbable to be able to remove just the ignition switch, as you have to turn the key to On first before the ignition switch will pull out.

    Third, having heavy keychains won't impact the ignition switch itself, as the ignition switch has some float built into it, plus the shaft that connects the tumbler to the switch is very solid and has little if any movement. You're more likely to affect the actual tumbler mechanism than the ignition switch.

    Here's some pics of the ignition switch disassembled. Forewarning, unless you really know what you're doing, I do NOT suggest disassembling your own switch, as it was quite a pain getting it back together. I was able to do it, but barely, and I was especially driven to get it back together since I didn't have a replacement for it. The biggest issue is getting the ball detents back in place, there are two of them so it makes it really tricky to get them back in.



    Here is a closer shot of the resistor



    This last one is a shot of the switch contacts. On the other part there is a set of phosphorous bronze springy fingers that contact the pads on the bottom, and a stamped phosphorous bronze three point contact that has a spring behind it to force it down.



    The circuit for the resistor is completed using the contacts at the bottom of the pic and the three fingered contact in the rotating part. The center of the switch has a plunger that is pushed down when you insert the key that pushes on the set of contacts you can see in the pic.

    After inspecting everything and figuring out how exactly the switch works, my theory is that over time the grease starts getting a build up of wear particles from the contacts and eventually creates intermittent shorts for the resistor, or at least changing the value of it. You cannot tell from the last pic as I had already wiped away the built up grease and wear particles, but you can see kind of what it looked like if you look at the top part of the pic.

    I could be completely wrong, but so far I haven't had a single issue since I took the switch apart and cleaned it. That was back on December 8th, so it's been about a month and a half now. While it's possible to take the switch out and spray it with electrical cleaner, I'm not sure how effective it'd be since it'd need to remove the grease, and then you're stuck with a switch that doesn't have any lubrication in it anymore and can suffer additional failures.
    2008 H3 Alpha
    2008 Victory Red H3

    "Live free or die: Death is not the worst of evils." - General John Stark

    N1JPA

  2. The Following User Says Thank You to JPaul For This Useful Post:

    scoreh3 (01-20-2018)

  3. #2
    El Diablo
    Join Date
    Sep 2011
    Location
    Scottsdale
    Posts
    8,588
    Thanks
    482
    Thanked 3,075 Times in 1,511 Posts
    Ironically, my H3 failed today just like Chris' did. I have the ignition housing and switch already (bought it a couple of years ago) we we're going to put that in soon.

  4. #3
    a.k.a. "The Jackal"

    Join Date
    Sep 2011
    Location
    Santa Clarita, Ca
    Posts
    8,830
    Thanks
    1,021
    Thanked 1,867 Times in 1,055 Posts
    Thanks for the all info on this being done! I was planning on doing it this weekend but plans changed. Been busy lately
    Squeaky3: 06 H3 ALPHA SAS Hi pinion Dana 44 front/Eaton HO72 rear 5.13 gears, custom crossmember for long arms, lockers, 4:1 T-case, v8 swap, gobi, Smittbilt 12k Custom bumpers....do it all vehicle

    "H3 front axles are like drunk cheerleaders....just use em until they get mouthy...then toss em and get another." -anonymous


  5. #4
    Street Tire
    Join Date
    Sep 2015
    Location
    PNW
    Posts
    373
    Thanks
    17
    Thanked 82 Times in 60 Posts
    I don't know why they don't sell the resistor portion separately. I've never replaced the whole switch, just swapped in the back half every time.
    09 H3T Alpha/Adv- |Tuned |Starr Hid |Thor Bumper |Airdoc |UCP |American Roll Tonneau |Arb Compressor |Katzkins |Kenwood |


 

Similar Threads

  1. H3T Ignition switch or electrical issue?
    By DFW Spartan in forum HUMMER H3 2006-2010; H3T 2009-2010
    Replies: 6
    Last Post: 07-15-2017, 02:16 PM
  2. Master Power Window Switch Front Driver Side - broken switch
    By H3ATH3N in forum HUMMER H3 2006-2010; H3T 2009-2010
    Replies: 10
    Last Post: 07-15-2014, 07:40 AM
  3. Possible Ignition Switch Problem???
    By 2007HummerH2 in forum HUMMER H2 2003-2009
    Replies: 0
    Last Post: 01-20-2014, 09:25 AM
  4. Did a bit of troubleshooting
    By LagunaH1 in forum HUMMER H1 1992-2006
    Replies: 4
    Last Post: 10-26-2012, 10:55 PM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Logout