Welcome to the H4O - HUMMER 4x4 Off Road.
Results 1 to 10 of 10
  1. #1
    Mud Terrain

    Join Date
    Sep 2011
    Location
    Sunset, Utah
    Posts
    911
    Thanks
    123
    Thanked 107 Times in 95 Posts

    How to disconnect Onstar in the H3

    OK folks this is how you can disconnect OnStar in the H3. The H3T should be similar.

    First put on parking break and place transmission in First Gear. Then turn key off. The radio will stay on. If you are worried about it. This is where you'll see the standard disconnect battery. I left mine connected.
    I then pulled the panel forward.
    Attached Images Attached Images   

    Know your Bugs Bunny.... Very important.

  2. #2
    Mud Terrain

    Join Date
    Sep 2011
    Location
    Sunset, Utah
    Posts
    911
    Thanks
    123
    Thanked 107 Times in 95 Posts
    With the panel removed and pushed to the side You can see the box at the bottom of the picture. I have already removed the two connections. I didn't have to disconnect the wires to the panel switches. You may need to.
    Attached Images Attached Images   

    Know your Bugs Bunny.... Very important.

  3. #3
    El Diablo
    Join Date
    Sep 2011
    Location
    Scottsdale
    Posts
    8,310
    Thanks
    457
    Thanked 2,963 Times in 1,443 Posts
    Thanks John for helping out the newbie.

  4. The Following User Says Thank You to alrock For This Useful Post:

    deserth3 (06-12-2017)

  5. #4
    Bald Tire
    Join Date
    Jun 2017
    Location
    ILLINOIS
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks John, I did exactly what you stated to do on the rear view mirror and with removing the 2 connections. They are just hanging but is there I reason I need to the wires to the panel switches? I am assuming the OnStar is now off. I again can't thank you enough for all your prompt and accurate and easy directions! Being on my own doing things now has been difficult but it is nice to know there are people like you who really want to help others without ripping them off!!! I owe you big time. I will check out all the links you sent me. Bonnie

  6. #5
    Mud Terrain

    Join Date
    Sep 2011
    Location
    Sunset, Utah
    Posts
    911
    Thanks
    123
    Thanked 107 Times in 95 Posts
    You only need to remove the two connectors to the onstar box.
    Removing connectors to the back of the panel just allows you more room to work. You can reconnect them when you put the panel back.
    You also don't need to disconnect the mirror. You need that connected for you compass and outside temp. Put after disconnecting onstar you will have one green light on the mirror still on. This is normal.

    Know your Bugs Bunny.... Very important.

  7. #6
    All Terrain
    Join Date
    Aug 2012
    Location
    SoCal
    Posts
    596
    Thanks
    114
    Thanked 101 Times in 85 Posts
    Where is the main fuse for the onstar ?

  8. #7
    Mud Terrain

    Join Date
    Sep 2011
    Location
    Sunset, Utah
    Posts
    911
    Thanks
    123
    Thanked 107 Times in 95 Posts
    I remember reading. It's an online fuse. I never bothered chasing it down from there.
    And as BMarino found out the hard way. The dealer doesn't know much about this system either.
    After many trips to the dealer she was told there was a parasitic drain caused by OnStar.
    I noticed a shorter battery life when I finally cancelled OnStar. But was ready for it thanks to other 06 owners who have complained about OnStar causing this in the past.
    I also figured that disconnecting the whole box was a better fix than just pulling the fuse. Troubleshooting an internal OnStar module problem without schematics just isn't worth my time and effort.

    Sent from my Moto G (4) using Tapatalk
    Last edited by deserth3; 06-15-2017 at 04:41 AM.

    Know your Bugs Bunny.... Very important.

  9. #8
    Super Swamper
    Join Date
    Feb 2013
    Location
    Wet Coast
    Posts
    3,488
    Thanks
    977
    Thanked 424 Times in 346 Posts
    So is that the main reason for someone to disconnect OnStar? Battery drain

    Sent from my SM-G935W8 using Tapatalk
    2009 Hummer H3T Alpha
    4 Rancho Lift, 37x12.5x17 BFG A/Ts, Method "The Standard" rims, Magnuson Supercharger, Magnaflow exhaust, 40" LED light bar, 9'' round LED spot lights, SnugTop, Thor Parts bumper w/ swing out for full sized spare, Hidden 9,500 lb Superwinch, Custom Sliders, UCP w/ Thor Parts skids, Custom bed cage

    www.ministryofadventure.ca

  10. #9
    Mud Terrain

    Join Date
    Sep 2011
    Location
    Sunset, Utah
    Posts
    911
    Thanks
    123
    Thanked 107 Times in 95 Posts
    Yes, for those that it's happening too. I've only heard of 06 and maybe 07 owners having this problem.
    There is also the matter OnStar knows where you truck is as long as the box is connected. This bothers some.
    And from what I've read they do keep track for " marketing reasons".

    Sent from my Moto G (4) using Tapatalk

    Know your Bugs Bunny.... Very important.

  11. The Following User Says Thank You to deserth3 For This Useful Post:

    RamRod (06-15-2017)

  12. #10
    Super Swamper
    Join Date
    Feb 2013
    Location
    Wet Coast
    Posts
    3,488
    Thanks
    977
    Thanked 424 Times in 346 Posts
    Quote Originally Posted by deserth3 View Post
    Yes, for those that it's happening too. I've only heard of 06 and maybe 07 owners having this problem.
    There is also the matter OnStar knows where you truck is as long as the box is connected. This bothers some.
    And from what I've read they do keep track for " marketing reasons"
    .

    Sent from my Moto G (4) using Tapatalk
    This is the part I was wondering about
    2009 Hummer H3T Alpha
    4 Rancho Lift, 37x12.5x17 BFG A/Ts, Method "The Standard" rims, Magnuson Supercharger, Magnaflow exhaust, 40" LED light bar, 9'' round LED spot lights, SnugTop, Thor Parts bumper w/ swing out for full sized spare, Hidden 9,500 lb Superwinch, Custom Sliders, UCP w/ Thor Parts skids, Custom bed cage

    www.ministryofadventure.ca


 

Similar Threads

  1. Jiffy Tite Disconnect Tool
    By 06PullUouT in forum HUMMER H3 2006-2010; H3T 2009-2010
    Replies: 5
    Last Post: 05-04-2016, 09:35 PM
  2. Quick disconnect tow rings
    By JPaul in forum HUMMER H3 2006-2010; H3T 2009-2010
    Replies: 16
    Last Post: 02-09-2016, 12:25 PM
  3. The Definitive FRONT Sway-bar Disconnect Answer
    By Steve #1 in forum HUMMER H3 2006-2010; H3T 2009-2010
    Replies: 17
    Last Post: 10-17-2015, 09:35 PM
  4. Disconnect the sensor plug and the vacuum hose on the throttle body... HOW...?
    By nelly27281 in forum HUMMER H3 2006-2010; H3T 2009-2010
    Replies: 3
    Last Post: 04-10-2013, 09:46 PM
  5. H3 XM/Onstar both died!
    By poncho1965 in forum HUMMER H3 2006-2010; H3T 2009-2010
    Replies: 10
    Last Post: 11-20-2012, 09:36 AM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Logout